No me funciona el Intellisense en visual studio 2008

Problema: No sé qué es lo que le he instalado al Visual Studio 2008, que desde hace unos días no me funciona el intellisense cuando trabajo con XAML (Ni con WPF ni con Silverlight)

Solución: Para ver si estamos hablando de lo mismo, comprueba en el registro (usando el regedit) si está vacía la entrada:

Para Windows de 32 bits:
HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

Para Windows de 64 bits:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

Si la entrada (Default) está vacía entonces el problema se puede solucionar de la siguiente forma:

Abriendo una ventana de símbolo de sistema y escribiendo(cuidado que en vista habrá que estar como administrador)
Para Windows de 32 bits:
regsvr32 "%CommonProgramFiles%\Microsoft Shared\MSEnv\TextMgrP.dll"

Para Windows de 64 bits:
regsvr32 "%CommonProgramFiles(X86)%\Microsoft Shared\MSEnv\TextMgrP.dll"

Reinicia el Visual Studio y listo.

Solución tomada de aquí

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s


A %d blogueros les gusta esto: